summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schuh <andreas.schuh.84@gmail.com>2016-11-24 23:15:34 +0000
committerAndreas Schuh <andreas.schuh.84@gmail.com>2016-11-24 23:30:55 +0000
commit18469830ae0419feed3747132a4aaf74d649b035 (patch)
treefd50b88b2b748bcfd584440e07e6b6e8278696e5 /CMakeLists.txt
parent3886da50e12408d0770fb689c32164ef70f200d6 (diff)
downloadgflags-18469830ae0419feed3747132a4aaf74d649b035.tar.gz
gflags-18469830ae0419feed3747132a4aaf74d649b035.tar.bz2
gflags-18469830ae0419feed3747132a4aaf74d649b035.zip
fix: Ensure installation path uses forward slashes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 898ac9f..15582cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,6 +133,10 @@ endif ()
# prefix for package variables in CMake configuration file
string (TOUPPER "${PACKAGE_NAME}" PACKAGE_PREFIX)
+# convert file path on Windows with back slashes to path with forward slashes
+# otherwise this causes an issue with the cmake_install.cmake script
+file (TO_CMAKE_PATH "${CMAKE_INSTALL_PREFIX}" CMAKE_INSTALL_PREFIX)
+
# ----------------------------------------------------------------------------
# options
@@ -196,6 +200,7 @@ endif ()
gflags_define (STRING INCLUDE_DIR "Name of include directory of installed header files relative to CMAKE_INSTALL_PREFIX/include/" "${PACKAGE_NAME}")
gflags_property (INCLUDE_DIR ADVANCED TRUE)
+file (TO_CMAKE_PATH "${INCLUDE_DIR}" INCLUDE_DIR)
if (IS_ABSOLUTE INCLUDE_DIR)
message (FATAL_ERROR "[GFLAGS_]INCLUDE_DIR must be a path relative to CMAKE_INSTALL_PREFIX/include/")
endif ()