summaryrefslogtreecommitdiff
path: root/contrib/gdk-pixbuf-xlib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/gdk-pixbuf-xlib/Makefile.am')
-rw-r--r--contrib/gdk-pixbuf-xlib/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/contrib/gdk-pixbuf-xlib/Makefile.am b/contrib/gdk-pixbuf-xlib/Makefile.am
new file mode 100644
index 0000000..d613555
--- /dev/null
+++ b/contrib/gdk-pixbuf-xlib/Makefile.am
@@ -0,0 +1,42 @@
+include $(top_srcdir)/Makefile.decl
+
+if PLATFORM_WIN32
+no_undefined = -no-undefined
+endif
+
+lib_LTLIBRARIES=libgdk_pixbuf_xlib-2.0.la
+
+INCLUDES = \
+ -I$(top_srcdir) -I$(top_builddir) \
+ -I$(top_srcdir)/gdk-pixbuf \
+ -I$(top_srcdir)/contrib \
+ $(GDK_PIXBUF_XLIB_DEP_CFLAGS)
+
+libgdk_pixbuf_xlib_2_0_la_LDFLAGS = \
+ -export-dynamic \
+ $(no_undefined) \
+ -version-info $(LT_VERSION_INFO)
+
+libgdk_pixbuf_xlib_2_0_la_LIBADD = \
+ $(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GDK_PIXBUF_API_VERSION).la \
+ $(GDK_PIXBUF_XLIB_DEP_LIBS)
+
+libgdk_pixbuf_xlib_2_0_la_SOURCES = \
+ gdk-pixbuf-xlib-private.h \
+ gdk-pixbuf-xlib.c \
+ gdk-pixbuf-xlib-render.c \
+ gdk-pixbuf-xlib-drawable.c \
+ gdk-pixbuf-xlibrgb.c
+
+libgdk_pixbuf_xlibincludedir=$(includedir)/gdk-pixbuf-2.0/gdk-pixbuf-xlib
+
+libgdk_pixbuf_xlibinclude_HEADERS = \
+ gdk-pixbuf-xlib.h \
+ gdk-pixbuf-xlibrgb.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gdk-pixbuf-xlib-2.0.pc
+
+EXTRA_DIST += gdk-pixbuf-xlib-2.0.pc.in
+
+-include $(top_srcdir)/git.mk