summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..6106910
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,34 @@
+include $(top_srcdir)/Makefile.decl
+
+SUBDIRS = gdk-pixbuf po docs tests contrib build
+
+EXTRA_DIST += config.h.win32
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gdk-pixbuf-2.0.pc
+
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+
+DISTCLEANFILES = \
+ gdk-pixbuf-2.0.pc
+
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-gtk-doc \
+ --enable-man \
+ --enable-introspection
+
+MAINTAINERCLEANFILES = \
+ ABOUT-NLS \
+ aclocal.m4 \
+ config.guess \
+ config.h.in \
+ config.rpath \
+ config.sub \
+ depcomp \
+ gtk-doc.make \
+ install-sh \
+ ltmain.sh \
+ missing
+
+
+-include $(top_srcdir)/git.mk