summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorANZ1217 <chihun.jeong@samsung.com>2024-02-26 21:16:23 +0900
committerANZ1217 <chihun.jeong@samsung.com>2024-02-26 21:51:32 +0900
commit8e1c3b5bebf664124e11de7e6c94beedcfe8ed31 (patch)
treec8a9b26f02bd4f7877e3014b1221b7d51c26fa6a /configure.ac
parent8b7d5aabf28cd73d25fe9155b6a4b50cc36325af (diff)
downloadfontconfig-8e1c3b5bebf664124e11de7e6c94beedcfe8ed31.tar.gz
fontconfig-8e1c3b5bebf664124e11de7e6c94beedcfe8ed31.tar.bz2
fontconfig-8e1c3b5bebf664124e11de7e6c94beedcfe8ed31.zip
Fix bug EFL cannot be built due to absence of UUID library This commit should be maintained after the next library upgrade. Please recommit this content after library update. Change-Id: I60297cbe33b0ceb6863eb56abddd040939289c1f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9a2c36f..c5e7e69f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -339,6 +339,39 @@ LIBS="$fontconfig_save_libs"
CFLAGS="$fontconfig_save_cflags"
#
+# Check for uuid
+#
+if test "$os_win32" != "yes"; then
+ use_pkgconfig_for_uuid=yes
+ if test -n "${UUID_LIBS}"; then
+ save_UUID_LIBS=$UUID_LIBS
+ fi
+ PKG_CHECK_MODULES([UUID], [uuid],
+ [use_pkgconfig_for_uuid=yes],
+ [use_pkgconfig_for_uuid=no])
+ if test "x$use_pkgconfig_for_uuid" = "xno"; then
+ AC_MSG_CHECKING([where uuid functions comes from])
+ AC_TRY_LINK([#include <uuid/uuid.h>],
+ [uuid_t a; uuid_generate(a);],
+ [AC_MSG_RESULT([builtin])
+ UUID_CFLAGS=""
+ UUID_LIBS=""
+ ],[AC_MSG_ERROR([
+*** uuid is required. install util-linux.
+ ])])
+ else
+ if test -z "${save_UUID_LIBS+x}" && test "x${UUID_LIBS}" != "x"; then
+ PKGCONFIG_REQUIRES_PRIVATELY="$PKGCONFIG_REQUIRES_PRIVATELY uuid"
+ fi
+ fi
+else
+ UUID_CFLAGS=""
+ UUID_LIBS=""
+fi
+AC_SUBST(UUID_CFLAGS)
+AC_SUBST(UUID_LIBS)
+
+#
# Check expat configuration
#
AC_ARG_WITH(expat,