summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMalar Kannan <malarkannan.invention@gmail.com>2019-11-15 06:28:35 +0530
committerWouter van Oortmerssen <aardappel@gmail.com>2019-11-14 16:58:35 -0800
commit6beb9f49cb44095c4c17be43f13906c6eb09d7c7 (patch)
tree37840c903e11db7f048658a6ffd52c2ee41cb7fb /CMakeLists.txt
parent80988ea869f7bbd5aff9283d49a03e297139ffa2 (diff)
downloadflatbuffers-6beb9f49cb44095c4c17be43f13906c6eb09d7c7.tar.gz
flatbuffers-6beb9f49cb44095c4c17be43f13906c6eb09d7c7.tar.bz2
flatbuffers-6beb9f49cb44095c4c17be43f13906c6eb09d7c7.zip
Support for python grpc - continuing the work from the pull request #4270 #4705 (#5613)
* Support for python grpc * add few fixes * Fixes build * Fix python generator * Add tests * Fix grpc python test * Fix tests and add incomplete python generator * Fix python generator * Add python generator methods * Fix Appveyor build * grpc python support v0.1 * Update tests * update grpctest * Remove duplicated code and fix a brace * tests for flatbuffers grpc python * Updated tests + removed SerializeToString, From String * remove pickle import * include missing files in ci - BUILD and generated test result
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a0f292ed..1b02d45c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,6 +104,9 @@ set(FlatBuffers_Compiler_SRCS
grpc/src/compiler/go_generator.cc
grpc/src/compiler/java_generator.h
grpc/src/compiler/java_generator.cc
+ grpc/src/compiler/python_generator.h
+ grpc/src/compiler/python_private_generator.h
+ grpc/src/compiler/python_generator.cc
)
set(FlatHash_SRCS