summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorrw <me@rwinslow.com>2014-12-16 00:32:11 -0800
committerrw <me@rwinslow.com>2015-05-12 15:40:29 -0700
commit48dfc69ee613a176f13b04c2310adb7a08fe6737 (patch)
tree9ec728d0b78951b40e42f1acb42f44520fe2bb3b /CMakeLists.txt
parent4d213c2d06fa17bec1dc87d16d02b8d94bc4fc58 (diff)
downloadflatbuffers-48dfc69ee613a176f13b04c2310adb7a08fe6737.tar.gz
flatbuffers-48dfc69ee613a176f13b04c2310adb7a08fe6737.tar.bz2
flatbuffers-48dfc69ee613a176f13b04c2310adb7a08fe6737.zip
Port FlatBuffers to Python.
Implement code generation and self-contained runtime library for Python. The test suite verifies: - Correctness of generated Python code by comparing output to that of the other language ports. - The exact bytes in the Builder buffer during many scenarios. - Vtable deduplication correctness. - Edge cases for table construction, via a fuzzer derived from the Go implementation. - All code is simultaneously valid in Python 2.6, 2.7, and 3.4. The test suite includes benchmarks for: - Building 'gold' data. - Parsing 'gold' data. - Deduplicating vtables. All tests pass on this author's system for the following Python implementations: - CPython 2.6.7 - CPython 2.7.8 - CPython 3.4.2 - PyPy 2.5.0 (CPython 2.7.8 compatible)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 39e65fae..5f3da26d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,7 @@ set(FlatBuffers_Compiler_SRCS
src/idl_gen_cpp.cpp
src/idl_gen_general.cpp
src/idl_gen_go.cpp
+ src/idl_gen_python.cpp
src/idl_gen_text.cpp
src/idl_gen_fbs.cpp
src/flatc.cpp