summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorXiaolei Yu <dreifachstein@gmail.com>2016-05-01 11:15:53 +0800
committerXiaolei Yu <dreifachstein@gmail.com>2016-05-01 11:15:53 +0800
commit3a8bc309e2ded37707d2f64935e3a8e14e3bf3db (patch)
tree4b3266e84b0dafa7d99eba36b68e2a7a79c8b0cd /CMakeLists.txt
parent77742a3fba232a256b54c8e6e2c2c8de9f8d1834 (diff)
downloadflatbuffers-3a8bc309e2ded37707d2f64935e3a8e14e3bf3db.tar.gz
flatbuffers-3a8bc309e2ded37707d2f64935e3a8e14e3bf3db.tar.bz2
flatbuffers-3a8bc309e2ded37707d2f64935e3a8e14e3bf3db.zip
Use the build output flatc to compile test schemas by default.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47a66e6c..b1e56d6b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -136,6 +136,9 @@ endif()
if(FLATBUFFERS_BUILD_FLATC)
add_executable(flatc ${FlatBuffers_Compiler_SRCS})
+ if(NOT FLATBUFFERS_FLATC_EXECUTABLE)
+ set(FLATBUFFERS_FLATC_EXECUTABLE $<TARGET_FILE:flatc>)
+ endif()
endif()
if(FLATBUFFERS_BUILD_FLATHASH)