summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMark Nauwelaerts <mark.nauwelaerts@gmail.com>2020-09-23 02:57:01 +0200
committerGitHub <noreply@github.com>2020-09-22 17:57:01 -0700
commit34d67b425e22ab8406eacc0a3a95e5bd60fd3300 (patch)
tree208d35ab48168751653c893c0f0de93cd01a55be /CMakeLists.txt
parent96d5e359773987314c25fa5181adb77c064ac625 (diff)
downloadflatbuffers-34d67b425e22ab8406eacc0a3a95e5bd60fd3300.tar.gz
flatbuffers-34d67b425e22ab8406eacc0a3a95e5bd60fd3300.tar.bz2
flatbuffers-34d67b425e22ab8406eacc0a3a95e5bd60fd3300.zip
Minireflect fixed array (#6129)
* CMakeLists: also really generate optional_scalars as needed by test elsewhere * [C++] Handle fixed-length array in minireflection Fixes #6128
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ca06af42..456d0bee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -478,6 +478,7 @@ if(FLATBUFFERS_BUILD_TESTS)
compile_flatbuffers_schema_to_cpp(tests/namespace_test/namespace_test1.fbs)
compile_flatbuffers_schema_to_cpp(tests/namespace_test/namespace_test2.fbs)
compile_flatbuffers_schema_to_cpp(tests/union_vector/union_vector.fbs)
+ compile_flatbuffers_schema_to_cpp(tests/optional_scalars.fbs)
compile_flatbuffers_schema_to_cpp_opt(tests/native_type_test.fbs "")
compile_flatbuffers_schema_to_cpp_opt(tests/arrays_test.fbs "--scoped-enums;--gen-compare")
compile_flatbuffers_schema_to_binary(tests/arrays_test.fbs)