summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormustiikhalil <mustii@mmk.one>2020-02-24 20:27:41 +0300
committerGitHub <noreply@github.com>2020-02-24 09:27:41 -0800
commit34305c4ce495bfc1f844ba62e3194d35f5707787 (patch)
tree36af010eca4e6f21e12d0d8efa843632074faf37 /CMakeLists.txt
parentcd88e6b2aa35b7e97f8146be8115a8ff420b1215 (diff)
downloadflatbuffers-34305c4ce495bfc1f844ba62e3194d35f5707787.tar.gz
flatbuffers-34305c4ce495bfc1f844ba62e3194d35f5707787.tar.bz2
flatbuffers-34305c4ce495bfc1f844ba62e3194d35f5707787.zip
[Swift] Adds GRPC to Swift (#5758)
* Adds the basic structure for required to add grpc support Added the message implementation Updated the code to confirm to the protocol flatbuffersobject Adds an example for Swift flatbuffers GRPC Started implementing the swift GRPC code Gen Generator generates protocols now Fixing ci issues Migrated the logic to use grpc_generator::File instead of string Refactored swift project Implemented GRPC in swift Finished implementing GRPC in swift Fixes issues Adds contiguousBytes initializer to swift Adds documentation + fixes buffer nameing in tables + structs Adds documentation + fixes buffer nameing in tables + structs Updated tests * Updated version
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00c409ef..f288bc56 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,6 +117,8 @@ set(FlatBuffers_Compiler_SRCS
grpc/src/compiler/python_generator.h
grpc/src/compiler/python_private_generator.h
grpc/src/compiler/python_generator.cc
+ grpc/src/compiler/swift_generator.h
+ grpc/src/compiler/swift_generator.cc
)
set(FlatHash_SRCS