summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDerek Bailey <derekbailey@google.com>2021-12-02 21:29:19 -0800
committerGitHub <noreply@github.com>2021-12-02 21:29:19 -0800
commit061d61f3f899866558cbb132b5306402aa1de9fb (patch)
treee4721fd2042dec2cb07fef1e84cdb92df5501fbe /CMakeLists.txt
parentcffe0c4546a2ddc2370a626ac4f7ef3da9df6953 (diff)
downloadflatbuffers-061d61f3f899866558cbb132b5306402aa1de9fb.tar.gz
flatbuffers-061d61f3f899866558cbb132b5306402aa1de9fb.tar.bz2
flatbuffers-061d61f3f899866558cbb132b5306402aa1de9fb.zip
Lua Generator using IR. (#6940)
* initial hack to get new Lua generator into flatc * Starting to output enum defs for Lua * Continue to work on table generation for Lua * Finished basic getter access for Lua * Added ability to get object by index * Finished struct builder * aliased reflection to r * finish table builder generation * register requiring files * better generated header info * Tying up loose ends * Updated reflection to handle struct padding * Addd type sizes to reflection * Fixed some vector indirect issues * Lua tests passed * Misc cleanup * ci fixes 1 * ci fixes 2 * renaming * up size of type sizes * manually ran clang-format-11 -i src/idl_parser.cpp * fixed some windows casting * remove stupid auto import * more static_casting * remove std * update other build environments * remove scoped enums * replaced std::to_string with NumToString * more win fixes * more win fixes * replaced old lua with new * removed auto import * review responses * more style fixes * refactor bfbs_gen_len to use code += * added consts * fix lambda capture for windows * remove unused return type
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df13bb25..ea8de4f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,6 +92,7 @@ set(FlatBuffers_Library_SRCS
include/flatbuffers/allocator.h
include/flatbuffers/array.h
include/flatbuffers/base.h
+ include/flatbuffers/bfbs_generator.h
include/flatbuffers/buffer.h
include/flatbuffers/buffer_ref.h
include/flatbuffers/default_allocator.h
@@ -139,7 +140,10 @@ set(FlatBuffers_Compiler_SRCS
src/idl_gen_swift.cpp
src/flatc.cpp
src/flatc_main.cpp
+ src/bfbs_gen.h
+ src/bfbs_gen_lua.h
include/flatbuffers/code_generators.h
+ src/bfbs_gen_lua.cpp
src/code_generators.cpp
grpc/src/compiler/schema_interface.h
grpc/src/compiler/cpp_generator.h