summaryrefslogtreecommitdiff
path: root/packaging/ejdb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/ejdb.spec')
-rw-r--r--packaging/ejdb.spec56
1 files changed, 56 insertions, 0 deletions
diff --git a/packaging/ejdb.spec b/packaging/ejdb.spec
new file mode 100644
index 0000000..4a08997
--- /dev/null
+++ b/packaging/ejdb.spec
@@ -0,0 +1,56 @@
+Name: ejdb
+Version: 1.2.12
+Release: 0
+License: LGPL-2.1+
+Source0: %{name}-%{version}.tar.gz
+Source1001: %{name}.manifest
+Summary: Embeddable document database
+Group: System/Database
+BuildRequires: cmake
+BuildRequires: pkgconfig(zlib)
+
+%description
+EJDB is the embeddable (in-process) database engine designed for
+querying collections of JSON documents and persisting data. EJDB is
+implemented as a C library based on Tokyo Cabinet key-value storage
+engine. EJDB design is inspired by Mongodb and follows the same
+philosophy, especially for the query language.
+
+%prep
+%setup -q
+cp %{SOURCE1001} .
+
+%build
+mkdir build
+cd build
+%cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ ../
+make %{?_smp_mflags}
+
+%install
+(cd build; %make_install)
+cat <<EOF >>documentation.list
+%{_prefix}/share/doc/ejdb/Changelog
+%exclude %{_prefix}/share/doc/ejdb/INSTALL
+%exclude %{_prefix}/share/doc/ejdb/LICENSE
+%{_prefix}/share/doc/ejdb/README
+EOF
+
+%files
+%license LICENSE
+%manifest %{name}.manifest
+%{_bindir}/jbbmgr
+%{_bindir}/jbfmgr
+%{_bindir}/jbhmgr
+%{_bindir}/jbtmgr
+%{_libdir}/libejdb.so.1*
+
+%docs_package
+
+%devel_package
+%files devel
+%{_datadir}/ejdb/*.cmake
+%{_includedir}/*
+%{_libdir}/*.so
+%{_libdir}/pkgconfig/*.pc