summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog23
-rw-r--r--debian/compat1
-rw-r--r--debian/control20
-rw-r--r--debian/dnsmasq.install.in1
-rwxr-xr-xdebian/rules118
-rw-r--r--debian/source/format1
6 files changed, 164 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..2cbf56b
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,23 @@
+dnsmasq (2.57-slp2+3) unstable; urgency=low
+
+ * Enable dbus feature
+ * Git: 165.213.180.234:/slp/pkgs/d/dnsmasq
+ * Tag: dnsmasq_2.57-slp2+3
+
+ -- Byeongho Shim <bh.shim@samsung.com> Mon, 07 Nov 2011 21:26:30 +0900
+
+dnsmasq (2.57-slp2+2) unstable; urgency=low
+
+ * Change the section on control file
+ * Git: 165.213.180.234:/slp/pkgs/d/dnsmasq
+ * Tag: dnsmasq_2.57-slp2+2
+
+ -- Byeongho Shim <bh.shim@samsung.com> Tue, 30 Aug 2011 09:59:52 +0900
+
+dnsmasq (2.57-slp2+1) unstable; urgency=low
+
+ * Initial Release.
+ * Git: 165.213.180.234:/slp/pkgs/d/dnsmasq
+ * Tag: dnsmasq_2.57-slp2+1
+
+ -- Byeongho Shim <bh.shim@samsung.com> Tue, 16 Aug 2011 16:43:13 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..edba10b
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,20 @@
+Source: dnsmasq
+Section: base
+Priority: extra
+Maintainer: Seungyoun Ju <sy39.ju@samsung.com>, Hocheol Seo <hocheol.seo@samsung.com>
+Build-Depends: debhelper (>= 5), libdbus-1-dev
+Standards-Version: 3.7.2
+
+Package: dnsmasq
+Section: base
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Dnsmasq is a lightweight, easy to configure DNS forwarder
+ and DHCP server.
+
+Package: dnsmasq-dbg
+Section: debug
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, dnsmasq (= ${Source-Version})
+Description: Dnsmasq is a lightweight, easy to configure DNS forwarder
+ and DHCP server.
diff --git a/debian/dnsmasq.install.in b/debian/dnsmasq.install.in
new file mode 100644
index 0000000..7346c45
--- /dev/null
+++ b/debian/dnsmasq.install.in
@@ -0,0 +1 @@
+@PREFIX@/bin/*
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..be777c3
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,118 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+CFLAGS ?= -Wall -g
+CXXFLAGS ?= -Wall -g
+LDFLAGS ?=
+PREFIX ?= /usr
+DATADIR ?= /opt
+
+CFLAGS += -fPIE
+CXXFLAGS += -fPIE
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+ CXXFLAGS += -O0
+else
+ CFLAGS += -O2
+ CXXFLAGS += -O2
+endif
+
+LDFLAGS += -Wl,--rpath=$(PREFIX)/lib -Wl,--hash-style=both -Wl,--as-needed -pie
+
+CMAKE_BUILD_DIR ?= $(CURDIR)/cmake_build_tmp
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && \
+ CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" cmake .. -DCMAKE_INSTALL_PREFIX=$(PREFIX)
+
+ touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ cd $(CMAKE_BUILD_DIR) && $(MAKE)
+
+ #docbook-to-man debian/wavplayer.sgml > wavplayer.1
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ cat $$f > $${f%.in}; \
+ sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
+ sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
+ done
+
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ rm -rf $(CMAKE_BUILD_DIR)
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ rm -f $${f%.in}; \
+ done
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/wavplayer.
+ cd $(CMAKE_BUILD_DIR) && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+# dh_installchangelogs
+# dh_installdocs
+# dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+# dh_installman
+ dh_link
+ dh_strip --dbg-package=dnsmasq-dbg
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)