summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2014-01-11 10:07:21 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2014-01-17 16:29:19 +0000
commit54440baa2192abe889957a23e4448c599ce32260 (patch)
tree7f2e459d208af9e44be7496db8d67a351443a581 /test/Makefile.am
parente782b0806eed9f46164b8aa5da7c1b12109175bf (diff)
downloaddbus-54440baa2192abe889957a23e4448c599ce32260.tar.gz
dbus-54440baa2192abe889957a23e4448c599ce32260.tar.bz2
dbus-54440baa2192abe889957a23e4448c599ce32260.zip
Rename spawn-test to test-spawn to match common test application naming scheme.
[Same change as for shell-test in the previous commit. -smcv] Bug: https://bugs.freedesktop.org/show_bug.cgi?id=73495 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index ddb69b4f..af2a0a23 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -61,7 +61,7 @@ if DBUS_ENABLE_EMBEDDED_TESTS
## break-loader removed for now
## these binaries are used in tests but are not themselves tests
TEST_BINARIES = \
- spawn-test \
+ test-spawn \
test-exit \
test-names \
test-segfault \
@@ -103,8 +103,9 @@ test_shell_service_LDADD = libdbus-testutils-internal.la
test_shell_SOURCES = shell-test.c
test_shell_CPPFLAGS = $(static_cppflags)
test_shell_LDADD = libdbus-testutils-internal.la
-spawn_test_CPPFLAGS = $(static_cppflags)
-spawn_test_LDADD = $(top_builddir)/dbus/libdbus-internal.la
+test_spawn_SOURCES = spawn-test.c
+test_spawn_CPPFLAGS = $(static_cppflags)
+test_spawn_LDADD = $(top_builddir)/dbus/libdbus-internal.la
test_printf_SOURCES = internals/printf.c
test_printf_CPPFLAGS = $(static_cppflags)