summaryrefslogtreecommitdiff
path: root/test/manual/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/manual/Makefile.am')
-rw-r--r--test/manual/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/test/manual/Makefile.am b/test/manual/Makefile.am
new file mode 100644
index 0000000..b028b6c
--- /dev/null
+++ b/test/manual/Makefile.am
@@ -0,0 +1,32 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/test/core \
+ -I$(top_builddir)/test/core \
+ $(DBUS_CFLAGS) \
+ $(DBUS_GLIB_CFLAGS) \
+ $(NULL)
+
+LDADD = \
+ $(top_builddir)/dbus/libdbus-glib-1.la \
+ $(DBUS_LIBS) \
+ $(DBUS_GLIB_LIBS) \
+ $(NULL)
+
+noinst_PROGRAMS = \
+ $(NULL)
+
+if DBUS_BUILD_TESTS
+noinst_PROGRAMS += \
+ test-invalid-usage \
+ $(NULL)
+endif
+
+# This "test" exercises invalid usage. It is deliberately not run in
+# TESTS, because it's (by design) full of bugs.
+test_invalid_usage_SOURCES = \
+ ../core/my-object-marshal.c \
+ ../core/my-object-marshal.h \
+ ../core/my-object.c \
+ ../core/my-object.h \
+ invalid-usage.c