summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDongHun Kwak <dh0128.kwak@samsung.com>2021-10-13 10:49:35 +0900
committerDongHun Kwak <dh0128.kwak@samsung.com>2021-10-13 10:49:35 +0900
commite31a2fb64fa509b9d22b7437b1833d6b0d62ee48 (patch)
tree0af002f5f8523176440deccb21b312aa5a83b0fc /configure.ac
parentc90fa15cbf2fc4380c58ff1b32f31d9ad6f57f81 (diff)
downloaddash-e31a2fb64fa509b9d22b7437b1833d6b0d62ee48.tar.gz
dash-e31a2fb64fa509b9d22b7437b1833d6b0d62ee48.tar.bz2
dash-e31a2fb64fa509b9d22b7437b1833d6b0d62ee48.zip
Imported Upstream version 0.5.10upstream/0.5.10
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9c4ced8..c36f949 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
-AC_INIT(dash, 0.5.9.1)
-AM_INIT_AUTOMAKE([foreign])
+AC_INIT(dash, 0.5.10)
+AM_INIT_AUTOMAKE([foreign subdir-objects])
AC_CONFIG_SRCDIR([src/main.c])
AC_CONFIG_HEADERS(config.h)
@@ -149,6 +149,20 @@ AC_CHECK_FUNC(open64,, [
AC_DEFINE(open64, open, [64-bit operations are the same as 32-bit])
])
+dnl Check if struct stat has st_mtim.
+AC_MSG_CHECKING(for stat::st_mtim)
+AC_COMPILE_IFELSE(
+[AC_LANG_PROGRAM([#include <time.h>
+#include <sys/time.h>
+#include <sys/stat.h>],
+[struct stat foo; return sizeof(foo.st_mtim.tv_sec)])],
+have_st_mtim=yes, have_st_mtim=no)
+AC_MSG_RESULT($have_st_mtim)
+if test "$have_st_mtim" = "yes"; then
+ AC_DEFINE([HAVE_ST_MTIM], [1],
+ [Define if your `struct stat' has `st_mtim'])
+fi
+
AC_ARG_WITH(libedit, AS_HELP_STRING(--with-libedit, [Compile with libedit support]))
use_libedit=
if test "$with_libedit" = "yes"; then