summaryrefslogtreecommitdiff
path: root/packaging/coreclr.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/coreclr.spec')
-rw-r--r--packaging/coreclr.spec14
1 files changed, 4 insertions, 10 deletions
diff --git a/packaging/coreclr.spec b/packaging/coreclr.spec
index 66bb4711d2..5e43f26bdc 100644
--- a/packaging/coreclr.spec
+++ b/packaging/coreclr.spec
@@ -347,7 +347,6 @@ export CLANG_NO_LIBDIR_SUFFIX=1
%define _buildtype %{dotnet_buildtype}
%define _reldir bin/Product/Linux.%{_barch}.%{_buildtype}
-%define _clrdebug 0
%define _paldebug 0
%if 0%{support_test}
@@ -356,15 +355,6 @@ export CLANG_NO_LIBDIR_SUFFIX=1
%define testopt 'skiptests'
%endif
-%if 0%{_clrdebug}
-export COMPlus_LogEnable=1
-export COMPlus_LogLevel=10
-export COMPlus_LogToFile=1
-export COMPlus_LogFile="clr.log"
-%else
-export COMPlus_LogEnable=0
-%endif
-
%if 0%{_paldebug}
export PAL_DBG_CHANNELS="+all.all"
export PAL_DBG_CHANNELS="+PAL.TRACE:-FILE.ERROR"
@@ -377,7 +367,11 @@ export PAL_DBG_CHANNELS=""
# for armoring request from PM group
# FIXME1: If you find better solution like CMAKE_CXX_FLAGS, please fix this
# FIXME2: This patch does not work on non-arm archtecture
+%if %{dotnet_buildtype} == "Release"
export CXXFLAGS+="-fstack-protector-strong -D_FORTIFY_SOURCE=2"
+%else
+export CXXFLAGS+="-fstack-protector-strong"
+%endif
%endif
%if 0%{skipmscorlib}