summaryrefslogtreecommitdiff
path: root/src/nativeresources/CMakeLists.txt
diff options
context:
space:
mode:
authorKyungwoo Lee <kyulee@microsoft.com>2015-12-03 14:26:05 -0800
committerKyungwoo Lee <kyulee@microsoft.com>2015-12-03 20:41:18 -0800
commit1d34f6293740f4f79f8b362c2d605fa2a527d538 (patch)
treea716d441f4449582b25bf2de9b264ba56fd8ee19 /src/nativeresources/CMakeLists.txt
parent0bdc646c5955ca0c735a3976d01969b246e848ef (diff)
downloadcoreclr-1d34f6293740f4f79f8b362c2d605fa2a527d538.tar.gz
coreclr-1d34f6293740f4f79f8b362c2d605fa2a527d538.tar.bz2
coreclr-1d34f6293740f4f79f8b362c2d605fa2a527d538.zip
Refactoring resource string
This pulls out resource string handling out of mscorrc into top level. The scripts (awk) are now parameterized to generate a unique string table for the given name. Added resourcestring.cpp to create an API "LoadResourceString". Added a few macros into resourcestring.h, which are used for definition/uses of the string table.
Diffstat (limited to 'src/nativeresources/CMakeLists.txt')
-rw-r--r--src/nativeresources/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/nativeresources/CMakeLists.txt b/src/nativeresources/CMakeLists.txt
new file mode 100644
index 0000000000..5bc326492a
--- /dev/null
+++ b/src/nativeresources/CMakeLists.txt
@@ -0,0 +1,9 @@
+project(nativeresourcestring)
+
+add_compile_options(-fPIC)
+
+add_library(nativeresourcestring
+ STATIC
+ resourcestring.cpp
+)
+