summaryrefslogtreecommitdiff
path: root/src/inc/CMakeLists.txt
diff options
context:
space:
mode:
authorSwaroop Sridhar <Swaroop.Sridhar@microsoft.com>2015-04-29 20:17:48 -0700
committerSwaroop Sridhar <Swaroop.Sridhar@microsoft.com>2015-05-05 13:39:09 -0700
commitb503f15c45f9a7e6d0f90e5f4f9d3985f2060fe8 (patch)
tree358b860c39546d3dac102b06fd4a0494f9543af0 /src/inc/CMakeLists.txt
parente79b36be0a49362908f5d191ca5b1f68eef8b39f (diff)
downloadcoreclr-b503f15c45f9a7e6d0f90e5f4f9d3985f2060fe8.tar.gz
coreclr-b503f15c45f9a7e6d0f90e5f4f9d3985f2060fe8.tar.bz2
coreclr-b503f15c45f9a7e6d0f90e5f4f9d3985f2060fe8.zip
GcInfo: Add support for Standalone build
The STANDALONE_BUILD switch can be used to build the GcInfoEncoder library independently by clients outside the CoreClr tree. The GcInfo library uses some custom data-structures (ex: ArrayList) and includes some utility libraries (ex: UtilCode) which pull in several other headers with considerable unrelated content. Rather than porting all the utility code to suite other clients, the STANDALONE_BUILD switch can be used to include only the minimal set of headers specific to GcInfo encodings. Clients of STANDALONE_BUILD will likely use standard library implementations of data-structures like ArrayList, HashMap etc., in place of the custom implementation currently used by GcInfoEncoder. Rather than spew the GcInfoEnoder code with #ifdef STANDALONE_BUILD ... #else .. #endif blocks, we include a special header GcInfoUtil.h in STANDALONE_BUILD mode. GcInfoUtil.h is expected to supply the interface/implementation for the data-structures and utilities used by GcInfoEncoder. This header should be provided by the clients doing the standalone build in their source tree.
Diffstat (limited to 'src/inc/CMakeLists.txt')
-rw-r--r--src/inc/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/inc/CMakeLists.txt b/src/inc/CMakeLists.txt
index be7f6d4329..6f4a1880c0 100644
--- a/src/inc/CMakeLists.txt
+++ b/src/inc/CMakeLists.txt
@@ -74,4 +74,6 @@ install (FILES cor.h
corjit.h
opcode.def
openum.h
+ gcinfoencoder.h
+ gcinfotypes.h
DESTINATION inc)