summaryrefslogtreecommitdiff
path: root/src/inc/CMakeLists.txt
diff options
context:
space:
mode:
authorkchoi <code.kchoi@gmail.com>2016-09-07 14:12:22 -0700
committerJan Vorlicek <janvorli@microsoft.com>2016-09-07 23:12:22 +0200
commit4149bd2070e0a8beec6dedb238e6fd832a39611b (patch)
tree7aa9401597ad87d4d1d902643439af1614458b99 /src/inc/CMakeLists.txt
parent09133905fce3b541702044b6d2bbe942a6b40155 (diff)
downloadcoreclr-4149bd2070e0a8beec6dedb238e6fd832a39611b.tar.gz
coreclr-4149bd2070e0a8beec6dedb238e6fd832a39611b.tar.bz2
coreclr-4149bd2070e0a8beec6dedb238e6fd832a39611b.zip
Fix strict aliasing violation from conditional typedef of wchar_t by building entire project as C++ for Unix (#6801)
Enable building CoreCLR as C++ project on Unix This series of patches fixes the strict aliasing violation from the conditional typedef of wchar_t in src/pal/inc/pal_char16.h:40 * rename c files to cpp * modify all cmake files to change .c files to .cpp * apply c++ linkage to templates
Diffstat (limited to 'src/inc/CMakeLists.txt')
-rw-r--r--src/inc/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/inc/CMakeLists.txt b/src/inc/CMakeLists.txt
index 803ca3bcc7..d38fa40773 100644
--- a/src/inc/CMakeLists.txt
+++ b/src/inc/CMakeLists.txt
@@ -50,23 +50,22 @@ add_compile_options(/TC)
else()
-#The MIDL tool exists for Windows only, so for other systems, we have the prebuilt xxx_i.c files checked in
+#The MIDL tool exists for Windows only, so for other systems, we have the prebuilt xxx_i.cpp files checked in
# The prebuilt files contain extra '!_MIDL_USE_GUIDDEF_' after the #endif, but not in the comment.
# In order to not to have to modify these prebuilt files, we disable the extra tokens warning.
add_compile_options(-Wno-extra-tokens)
-
+add_compile_options(-D_MIDL_USE_GUIDDEF_)
foreach(IDL_SOURCE IN LISTS CORGUIDS_IDL_SOURCES)
get_filename_component(IDLNAME ${IDL_SOURCE} NAME_WE)
- set(C_SOURCE ../pal/prebuilt/idl/${IDLNAME}_i.c)
+ set(C_SOURCE ../pal/prebuilt/idl/${IDLNAME}_i.cpp)
list(APPEND CORGUIDS_SOURCES ${C_SOURCE})
endforeach(IDL_SOURCE)
add_compile_options(-fPIC)
-
endif(WIN32)
-# Compile *_i.c to lib
+# Compile *_i.cpp to lib
_add_library(corguids ${CORGUIDS_SOURCES})
# Binplace the inc files for packaging later.