summaryrefslogtreecommitdiff
path: root/src/dlls/dbgshim/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2015-05-01 16:30:38 -0700
committerMike McLaughlin <mikem@microsoft.com>2015-05-02 11:10:48 -0700
commiteb798177505eefad288dc28bcf86028ce4d8ba57 (patch)
tree131b5e67bb0c56af0c187d3a5e230a7a2af94e36 /src/dlls/dbgshim/CMakeLists.txt
parent25272dba24d166f8075c28cce08ac911941fcfc0 (diff)
downloadcoreclr-eb798177505eefad288dc28bcf86028ce4d8ba57.tar.gz
coreclr-eb798177505eefad288dc28bcf86028ce4d8ba57.tar.bz2
coreclr-eb798177505eefad288dc28bcf86028ce4d8ba57.zip
Fixed PAL thread allocation stack overflow.
Add -Bsymbolic linker option to prevent static variables from being shared across PAL instances Install coreclrpal and palrt libraries so VS has easy access to link against them. Don't install the debug-pal library to binary directory. Fix "corerun" lldb test command.
Diffstat (limited to 'src/dlls/dbgshim/CMakeLists.txt')
-rw-r--r--src/dlls/dbgshim/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/dlls/dbgshim/CMakeLists.txt b/src/dlls/dbgshim/CMakeLists.txt
index 7eef457bc7..c5b8b9f483 100644
--- a/src/dlls/dbgshim/CMakeLists.txt
+++ b/src/dlls/dbgshim/CMakeLists.txt
@@ -25,7 +25,7 @@ endif(CLR_CMAKE_PLATFORM_UNIX)
if(CLR_CMAKE_PLATFORM_LINUX)
# This option is necessary to ensure that the overloaded delete operator defined inside
# of the utilcode will be used instead of the standard library delete operator.
- set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Xlinker -Bsymbolic-functions")
+ set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Xlinker -Bsymbolic -Bsymbolic-functions")
endif(CLR_CMAKE_PLATFORM_LINUX)
add_library(dbgshim SHARED ${DBGSHIM_SOURCES})