summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGeoff Norton <grompf@gmail.com>2015-02-06 22:41:41 -0800
committerGeoff Norton <grompf@gmail.com>2015-02-06 22:41:41 -0800
commit0ed1ff2c65d54450d078b0ac65d4c13ddb239a6c (patch)
tree6d1e0ecc9c7c0b1b860112dc1f3a7d83c30d15f8 /src/CMakeLists.txt
parentbb38f10ec8efea85a85b57669b161a2cd0beb1dd (diff)
downloadcoreclr-0ed1ff2c65d54450d078b0ac65d4c13ddb239a6c.tar.gz
coreclr-0ed1ff2c65d54450d078b0ac65d4c13ddb239a6c.tar.bz2
coreclr-0ed1ff2c65d54450d078b0ac65d4c13ddb239a6c.zip
-nostdinc++ is not recognized by apple clang, but its also not needed
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2822facb71..642e66a9ce 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -16,8 +16,12 @@ else(WIN32)
enable_language(ASM)
# This prevents inclusion of standard C compiler headers
add_compile_options(-nostdinc)
-# This prevents inclusion of standard C++ compiler headers
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -nostdinc++")
+
+if(NOT CLR_CMAKE_PLATFORM_DARWIN)
+ # This prevents inclusion of standard C++ compiler headers
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -nostdinc++")
+endif(NOT CLR_CMAKE_PLATFORM_DARWIN)
+
endif(WIN32)
add_subdirectory(utilcode)