summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGaurav Khanna <gkhanna@microsoft.com>2016-03-03 18:10:26 -0800
committerGaurav Khanna <gkhanna@microsoft.com>2016-03-04 09:24:34 -0800
commitf8dfa40dc21c01e4dc297aeb4a23db22d1830506 (patch)
tree7faf98239420c59c61f9c29c0e8f60d2fad566fb /CMakeLists.txt
parentd31008b8ee2ad0303d90905188e50d3f6cd8e166 (diff)
downloadcoreclr-f8dfa40dc21c01e4dc297aeb4a23db22d1830506.tar.gz
coreclr-f8dfa40dc21c01e4dc297aeb4a23db22d1830506.tar.bz2
coreclr-f8dfa40dc21c01e4dc297aeb4a23db22d1830506.zip
Fixup CRT linkages for uCRT
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f4b59e8104..6be44237c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -617,8 +617,18 @@ endif (CLR_CMAKE_PLATFORM_UNIX)
# Libraries
if (WIN32)
+
+ # Define the CRT lib references that link into Desktop imports
set(STATIC_MT_CRT_LIB "libcmt$<$<OR:$<CONFIG:Debug>,$<CONFIG:Checked>>:d>.lib")
+ set(STATIC_MT_VCRT_LIB "libvcruntime$<$<OR:$<CONFIG:Debug>,$<CONFIG:Checked>>:d>.lib")
set(STATIC_MT_CPP_LIB "libcpmt$<$<OR:$<CONFIG:Debug>,$<CONFIG:Checked>>:d>.lib")
+
+ # ARM64_TODO: Enable this for Windows Arm64
+ if (NOT CLR_CMAKE_PLATFORM_ARCH_ARM64)
+ # Define the uCRT lib reference
+ set(STATIC_MT_UCRT_LIB "libucrt$<$<OR:$<CONFIG:Debug>,$<CONFIG:Checked>>:d>.lib")
+ endif()
+
endif(WIN32)
# Definition directives