summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSean Gillespie <sean@swgillespie.me>2017-01-23 19:44:10 -0800
committerJan Kotas <jkotas@microsoft.com>2017-01-23 19:44:10 -0800
commitbbd32c484f2d00a566217e52bddb6960c2ec0b22 (patch)
tree2e993c5409feea679563ac18fd5f7600e1412642 /CMakeLists.txt
parentd8b995b42714f4e83e0ee35a8ff481143cd62994 (diff)
downloadcoreclr-bbd32c484f2d00a566217e52bddb6960c2ec0b22.tar.gz
coreclr-bbd32c484f2d00a566217e52bddb6960c2ec0b22.tar.bz2
coreclr-bbd32c484f2d00a566217e52bddb6960c2ec0b22.zip
[Local GC] Provide an implementation of GCToOSInterface for Unix-like platforms (#8976)
* Add way to build with FEATURE_STANDALONE_GC from build.sh * Make CMake changes to build the GC 'PAL' as its own build target (to avoid -nostdinc). In addition, introduce a "GC PAL" that provides an implementation of GCToOSInterface on Unix-like platforms, for use with FEATURE_STANDALONE_GC.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2c39780e29..cdf157e186 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -579,6 +579,14 @@ endif(WIN32)
include_directories("src/pal/prebuilt/inc")
include_directories("bin/obj")
+if(FEATURE_STANDALONE_GC)
+ add_definitions(-DFEATURE_STANDALONE_GC)
+
+ if(CLR_CMAKE_PLATFORM_UNIX)
+ add_subdirectory(src/gc/unix)
+ endif(CLR_CMAKE_PLATFORM_UNIX)
+endif(FEATURE_STANDALONE_GC)
+
if (CLR_CMAKE_PLATFORM_UNIX)
include_directories("src/pal/inc")
include_directories("src/pal/inc/rt")