summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrian Robbins <brianrob@microsoft.com>2015-10-07 15:47:02 -0700
committerBrian Robbins <brianrob@microsoft.com>2015-10-07 15:47:02 -0700
commitb55cc2dfbd1486101d23d829f6e4e1313089ca35 (patch)
tree31effa710fe7ad588ac14e26d2543b7c2917fcb6 /CMakeLists.txt
parentee41080d445be450352370a8cf12a12c5b3aeaec (diff)
parentebc35416c4b57a3415f4f1bbde385e159eb520ca (diff)
downloadcoreclr-b55cc2dfbd1486101d23d829f6e4e1313089ca35.tar.gz
coreclr-b55cc2dfbd1486101d23d829f6e4e1313089ca35.tar.bz2
coreclr-b55cc2dfbd1486101d23d829f6e4e1313089ca35.zip
Merge pull request #1696 from brianrob/framepointers
Enable Frame Pointers for UNIX Builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 610e929d33..aa28a5f0f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -395,6 +395,9 @@ add_compile_options(-fms-extensions )
#-fms-compatibility Enable full Microsoft Visual C++ compatibility
#-fms-extensions Accept some non-standard constructs supported by the Microsoft compiler
+# Disable frame pointer optimizations so profilers can get better call stacks
+add_compile_options(-fno-omit-frame-pointer)
+
endif(CLR_CMAKE_PLATFORM_UNIX)
add_subdirectory(src/debug/debug-pal)