summaryrefslogtreecommitdiff
path: root/packaging/connman.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/connman.spec')
-rw-r--r--packaging/connman.spec25
1 files changed, 23 insertions, 2 deletions
diff --git a/packaging/connman.spec b/packaging/connman.spec
index 33b9ccfc..6d17cd99 100644
--- a/packaging/connman.spec
+++ b/packaging/connman.spec
@@ -1,11 +1,12 @@
%bcond_with connman_openconnect
+%bcond_with connman_wireguard
%bcond_without connman_openvpn
%bcond_without connman_ipsec
%bcond_without connman_vpnd
Name: connman
-Version: 1.37
-Release: 50
+Version: 1.38
+Release: 1
License: GPL-2.0+
Summary: Connection Manager
Url: http://connman.net
@@ -88,6 +89,16 @@ Requires: %{name} = %{version}
Provides VPN support for Connman
%endif
+%if %{with connman_wireguard}
+%package plugin-wireguard
+Summary: Wireguard Support for Connman
+BuildRequires: pkgconfig(libmnl)
+Requires: %{name} = %{version}
+
+%description plugin-wireguard
+Wireguard Support for Connman.
+%endif
+
%package test
Summary: Test Scripts for Connection Manager
Group: Development/Tools
@@ -164,6 +175,9 @@ chmod +x bootstrap
%if %{with connman_ipsec}
--enable-ipsec \
%endif
+%if %{without connman_wireguard}
+ --disable-wireguard \
+%endif
%if 0%{?enable_connman_features}
%connman_features \
%endif
@@ -290,6 +304,13 @@ systemctl daemon-reload
%attr(644,root,root) %{_unitdir}/connman-vpn.service
%endif
+%if %{with connman_wireguard}
+%files plugin-wireguard
+%manifest %{name}.manifest
+%{_libdir}/%{name}/plugins-vpn/wireguard.so
+%license COPYING
+%endif
+
%post extension-tv
mv -f %{_unitdir}/connman.service.tv %{_unitdir}/connman.service
mv -f %{_sysconfdir}/connman/main.conf.tv %{_sysconfdir}/connman/main.conf