summaryrefslogtreecommitdiff
path: root/packaging/compositeproto.spec
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-10-30 17:13:49 -0700
committerAnas Nashif <anas.nashif@intel.com>2013-05-11 02:15:33 -0400
commit69232f100a88d752d3aaa20599f3aafe8c34587c (patch)
tree29af3025c21178c5a4712576cf5dfbefde9901cf /packaging/compositeproto.spec
parentd8a4d63f76820a816b2ee11b8666110cc6762bf7 (diff)
downloadcompositeproto-69232f100a88d752d3aaa20599f3aafe8c34587c.tar.gz
compositeproto-69232f100a88d752d3aaa20599f3aafe8c34587c.tar.bz2
compositeproto-69232f100a88d752d3aaa20599f3aafe8c34587c.zip
add packaging
Diffstat (limited to 'packaging/compositeproto.spec')
-rw-r--r--packaging/compositeproto.spec46
1 files changed, 46 insertions, 0 deletions
diff --git a/packaging/compositeproto.spec b/packaging/compositeproto.spec
new file mode 100644
index 0000000..a8db434
--- /dev/null
+++ b/packaging/compositeproto.spec
@@ -0,0 +1,46 @@
+Name: compositeproto
+Summary: X.Org X11 Protocol compositeproto
+Version: 0.4.2
+Release: 1
+Group: Development/System
+License: MIT
+URL: http://www.x.org
+Source0: %{name}-%{version}.tar.gz
+Provides: compositeproto
+
+BuildRequires: pkgconfig
+BuildRequires: pkgconfig(xorg-macros)
+
+# some file to be intalled can be ignored when rpm generates packages
+%define _unpackaged_files_terminate_build 0
+
+%description
+Description: %{summary}
+
+%prep
+%setup -q
+
+%build
+
+./autogen.sh
+%reconfigure --disable-static \
+ --libdir=%{_datadir} \
+ --without-xmlto
+
+# Call make instruction with smp support
+make %{?jobs:-j%jobs}
+
+%install
+rm -rf %{buildroot}
+%make_install
+
+%remove_docs
+
+%clean
+rm -rf %{buildroot}
+
+%files
+%defattr(-,root,root,-)
+%{_includedir}/X11/extensions/*
+%{_datadir}/pkgconfig/*
+