summaryrefslogtreecommitdiff
path: root/packaging/cmake.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/cmake.spec')
-rw-r--r--packaging/cmake.spec5
1 files changed, 4 insertions, 1 deletions
diff --git a/packaging/cmake.spec b/packaging/cmake.spec
index e23670603..07d7a9cee 100644
--- a/packaging/cmake.spec
+++ b/packaging/cmake.spec
@@ -36,7 +36,6 @@ cp %{SOURCE1001} .
%build
export CXXFLAGS="$RPM_OPT_FLAGS -fPIC -pie"
export CFLAGS="$CXXFLAGS"
-
# Set up default CMake configuration for ranlib, ar and nm, so we can build
# both CMake and target packages with LTO
insertconfline() {
@@ -47,6 +46,10 @@ insertconfline "set (CMAKE_RANLIB \"$(which %__ranlib)\" CACHE FILEPATH \"Path t
insertconfline "set (CMAKE_AR \"$(which %__ar)\" CACHE FILEPATH \"Path to ar tool.\" FORCE)"
insertconfline "set (CMAKE_NM \"$(which %__nm)\" CACHE FILEPATH \"Path to nm tool.\" FORCE)"
+%if 0%{?asan}
+sed -i '1719s/libs=\"${libs} -ldl -lrt\"/libs=\"${libs} -ldl -lrt -lasan\"/' bootstrap
+%endif
+
./configure \
--prefix=%{_prefix} \
--datadir=/share/%{name} \