summaryrefslogtreecommitdiff
path: root/Tests/HIP/ArchitectureOff/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/HIP/ArchitectureOff/CMakeLists.txt')
-rw-r--r--Tests/HIP/ArchitectureOff/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/HIP/ArchitectureOff/CMakeLists.txt b/Tests/HIP/ArchitectureOff/CMakeLists.txt
new file mode 100644
index 000000000..bccb3b4f8
--- /dev/null
+++ b/Tests/HIP/ArchitectureOff/CMakeLists.txt
@@ -0,0 +1,8 @@
+cmake_minimum_required(VERSION 3.18)
+project(HIPArchitecture HIP)
+
+# Make sure CMake doesn't pass architectures if HIP_ARCHITECTURES is OFF.
+string(APPEND CMAKE_HIP_FLAGS " --offload-arch=gfx908")
+
+add_executable(HIPOnlyArchitectureOff main.hip)
+set_property(TARGET HIPOnlyArchitectureOff PROPERTY HIP_ARCHITECTURES OFF)