summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNuno Subtil <nsubtil@nvidia.com>2015-04-01 19:10:55 -0700
committerNuno Subtil <nsubtil@nvidia.com>2015-04-01 19:15:42 -0700
commit10ddfd32cb5ca4132902e9453fb05242ef52ec07 (patch)
tree14638a35bafb39f90a2b8507228d9c1d3abe3cb4 /CMakeLists.txt
parent2a7fe03b5d5d7e1d30a1eb0b0e894eb4f72d3701 (diff)
downloadcaffeonacl-10ddfd32cb5ca4132902e9453fb05242ef52ec07.tar.gz
caffeonacl-10ddfd32cb5ca4132902e9453fb05242ef52ec07.tar.bz2
caffeonacl-10ddfd32cb5ca4132902e9453fb05242ef52ec07.zip
Build gflags and glog through CMake if not found in the system
This adds functionality to fetch gflags and glog from GitHub and build them during the Caffe build. This happens only if a system-wide installed version is not found (i.e., when find_package() fails). If built as part of the Caffe build, gflags and glog are compiled as position-independent static libraries. This avoids doing a system-wide install of these libraries during the Caffe install target.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74fa70c9..f22aa576 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,8 @@ project(Caffe C CXX)
# ---[ Using cmake scripts and modules
list(APPEND CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake/Modules)
+include(ExternalProject)
+
include(cmake/Utils.cmake)
include(cmake/Targets.cmake)
include(cmake/Misc.cmake)