summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2007-02-22 02:51:54 +0000
committerYang Tse <yangsita@gmail.com>2007-02-22 02:51:54 +0000
commit915e774a42ad19ad9e8afb8c21ccee88ade22a94 (patch)
tree760640e0797b16889555a0e5c8c52023041e2fe6 /configure.ac
parent5f5a8ca90580d8fb12f7c3a843ce5a203942dab5 (diff)
downloadc-ares-915e774a42ad19ad9e8afb8c21ccee88ade22a94.tar.gz
c-ares-915e774a42ad19ad9e8afb8c21ccee88ade22a94.tar.bz2
c-ares-915e774a42ad19ad9e8afb8c21ccee88ade22a94.zip
Check for stdbool.h at configuration stage, and include it if available.
Check for lowercase 'bool' type at configuration stage. If not available provide a suitable replacement with a type definition of 'unsigned char' in setup_once.h Move definitions of TRUE and FALSE to setup_once.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0165c5e..e870d63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -308,6 +308,8 @@ AC_CHECK_HEADERS(
netdb.h \
netinet/in.h \
net/if.h \
+ errno.h \
+ stdbool.h \
arpa/nameser.h \
arpa/nameser_compat.h \
arpa/inet.h,
@@ -369,6 +371,16 @@ fi
AC_CHECK_TYPE(ssize_t, ,
AC_DEFINE(ssize_t, int, [the signed version of size_t]))
+# check for bool type
+AC_CHECK_TYPE([bool],[
+ AC_DEFINE(HAVE_BOOL_T, 1,
+ [Define to 1 if bool is an available type.])
+], ,[
+#ifdef HAVE_STDBOOL_H
+#include <stdbool.h>
+#endif
+])
+
# Check for socklen_t or equivalent
CURL_CHECK_TYPE_SOCKLEN_T