summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-07-16 14:17:56 +0000
committerYang Tse <yangsita@gmail.com>2008-07-16 14:17:56 +0000
commit6b84d9ff24e5d4921fb12f43b66f2b668b42bd06 (patch)
treeeec7ec546b4eb5d3dd3fe20de5ce110fa20cb739 /configure.ac
parentb95f5e5bedbefaa2d6273af0afe86de075f20c77 (diff)
downloadc-ares-6b84d9ff24e5d4921fb12f43b66f2b668b42bd06.tar.gz
c-ares-6b84d9ff24e5d4921fb12f43b66f2b668b42bd06.tar.bz2
c-ares-6b84d9ff24e5d4921fb12f43b66f2b668b42bd06.zip
Initial DEC/Compaq C compiler detection and flags
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 80eecda..57f16c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,6 +231,22 @@ else
AC_MSG_RESULT([no])
fi
+AC_MSG_CHECKING([whether we are using the DEC/Compaq C compiler])
+CURL_CHECK_DEF([__DECC], [], [silent])
+CURL_CHECK_DEF([__DECC_VER], [], [silent])
+if test "$curl_cv_have_def___DECC" = "yes" ||
+ test "$curl_cv_have_def___DECC_VER" = "yes"; then
+ AC_MSG_RESULT([yes])
+ dnl Select strict ANSI C compiler mode
+ CFLAGS="$CFLAGS -std1"
+ dnl Generate verbose messages for errors and warnings
+ CFLAGS="$CFLAGS -verbose"
+ dnl Generate warnings for missing function prototypes
+ CFLAGS="$CFLAGS -warnprotos"
+else
+ AC_MSG_RESULT([no])
+fi
+
CURL_CHECK_COMPILER_HALT_ON_ERROR
CURL_CHECK_COMPILER_ARRAY_SIZE_NEGATIVE