summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2006-05-24 23:02:51 +0000
committerDaniel Stenberg <daniel@haxx.se>2006-05-24 23:02:51 +0000
commit2fc66d7b0131f33261ecd3f9a2ddd8b827ec8a52 (patch)
tree39e195eda4171054a61f3744a1c85be64fbc9826 /configure.ac
parente75c876ac50b7e38e7ca0897e79a9f5f02d319cd (diff)
downloadc-ares-2fc66d7b0131f33261ecd3f9a2ddd8b827ec8a52.tar.gz
c-ares-2fc66d7b0131f33261ecd3f9a2ddd8b827ec8a52.tar.bz2
c-ares-2fc66d7b0131f33261ecd3f9a2ddd8b827ec8a52.zip
Copied the NO_UNDEFINED magic from libcurl to make this build fine again with
libtool cross-compiled on linux with mingw32
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f862f8b..8f903a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,18 @@ dnl libtool setup
CARES_CLEAR_LIBTOOL_TAGS
AC_PROG_LIBTOOL
+AC_MSG_CHECKING([if we need -no-undefined])
+case $host in
+ *-*-cygwin | *-*-mingw* | *-*-pw32*)
+ need_no_undefined=yes
+ ;;
+ *)
+ need_no_undefined=no
+ ;;
+esac
+AC_MSG_RESULT($need_no_undefined)
+AM_CONDITIONAL(NO_UNDEFINED, test x$need_no_undefined = xyes)
+
dnl Checks for header files.
AC_HEADER_STDC