summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2007-03-07 01:13:03 +0000
committerYang Tse <yangsita@gmail.com>2007-03-07 01:13:03 +0000
commit2077aa08599bc0087271d10d463f0518978d755f (patch)
treeaf2e63377fb38b91877b5283ccdd212494376618 /configure.ac
parentfd68050fae28cf7992aae63fac833d0fe0fb05e4 (diff)
downloadc-ares-2077aa08599bc0087271d10d463f0518978d755f.tar.gz
c-ares-2077aa08599bc0087271d10d463f0518978d755f.tar.bz2
c-ares-2077aa08599bc0087271d10d463f0518978d755f.zip
Autoconf redefines the M4 builtin macro 'm4_undefine' in such a way that
it fails if the macro that is being undefined is not already defined. To make this work under all cases and be sure that at a certain point some specific macro isn't defined we must use the following style in configure: m4_ifdef([macro], [m4_undefine([macro])])
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2d09dba..09eb4ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,11 +64,15 @@ AC_HELP_STRING([--disable-debug],[Disable debug options]),
)
dnl skip libtool C++ and Fortran compiler checks
+m4_ifdef([AC_PROG_CXX], [m4_undefine([AC_PROG_CXX])])
m4_defun([AC_PROG_CXX],[])
+m4_ifdef([AC_PROG_F77], [m4_undefine([AC_PROG_F77])])
m4_defun([AC_PROG_F77],[])
dnl skip libtool C++ and Fortran linker checks
+m4_ifdef([AC_LIBTOOL_CXX], [m4_undefine([AC_LIBTOOL_CXX])])
m4_defun([AC_LIBTOOL_CXX],[])
+m4_ifdef([AC_LIBTOOL_F77], [m4_undefine([AC_LIBTOOL_F77])])
m4_defun([AC_LIBTOOL_F77],[])
dnl libtool setup