summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2004-02-15 12:30:40 +0000
committerDaniel Stenberg <daniel@haxx.se>2004-02-15 12:30:40 +0000
commit15d2d14259ae643d6e067232b36a6b433fc31632 (patch)
tree3cf5ade2b84c8b9ac1ce4b14502ec7ee4056ba51 /configure.ac
parent59c69ebd1a617a0183c2321538070995e7ba4b66 (diff)
downloadc-ares-15d2d14259ae643d6e067232b36a6b433fc31632.tar.gz
c-ares-15d2d14259ae643d6e067232b36a6b433fc31632.tar.bz2
c-ares-15d2d14259ae643d6e067232b36a6b433fc31632.zip
don't assume we can use gcc 2.96+ options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 448faec..362370d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,9 @@ AC_HELP_STRING([--disable-debug],[Disable debug options]),
CPPFLAGS="$CPPFLAGS -DCURLDEBUG"
CFLAGS="$CFLAGS -g"
if test "$GCC" = "yes"; then
- CFLAGS="$CFLAGS -W -Wall -Wwrite-strings -pedantic -Wno-long-long -Wundef -Wpointer-arith -Wnested-externs -Wcast-align -Winline -Wstrict-prototypes -Wmissing-declarations -Wmissing-prototypes -Wshadow -Wfloat-equal -Wsign-compare -Wunreachable-code"
+ dnl these work for gcc 2.95
+ CFLAGS="$CFLAGS -W -Wall -Wwrite-strings -pedantic -Wno-long-long -Wundef -Wpointer-arith -Wnested-externs -Wcast-align -Winline -Wstrict-prototypes -Wmissing-declarations -Wmissing-prototypes -Wshadow -Wsign-compare"
+ dnl 2.96 or higher: -Wfloat-equal -Wunreachable-code
fi
dnl strip off optimizer flags
NEWFLAGS=""