summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSeonah Moon <seonah1.moon@samsung.com>2020-12-15 19:56:19 +0900
committerSeonah Moon <seonah1.moon@samsung.com>2020-12-15 19:58:58 +0900
commitbff27be9aa171a5afc25df79cd652337aa1ecbb0 (patch)
treebdfd96ad0138ccded52d4194d101dcc3eb7d959b /Makefile.am
parent8e609b5f488d486a9e066ed494218d966f489938 (diff)
downloadc-ares-bff27be9aa171a5afc25df79cd652337aa1ecbb0.tar.gz
c-ares-bff27be9aa171a5afc25df79cd652337aa1ecbb0.tar.bz2
c-ares-bff27be9aa171a5afc25df79cd652337aa1ecbb0.zip
Imported Upstream version 1.17.1upstream/1.17.1
Change-Id: Ifb18ec521bbeaf8bac560e0588657f136ca93e5d
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am202
1 files changed, 13 insertions, 189 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ba40ba..eef3d3d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,207 +1,31 @@
-AUTOMAKE_OPTIONS = foreign nostdinc
+AUTOMAKE_OPTIONS = foreign nostdinc 1.9.6
+ACLOCAL_AMFLAGS = -I m4 --install
-ACLOCAL_AMFLAGS = -I m4
-
-# Specify our include paths here, and do it relative to $(top_srcdir) and
-# $(top_builddir), to ensure that these paths which belong to the library
-# being currently built and tested are searched before the library which
-# might possibly already be installed in the system.
-#
-# When using the low-level hard-hacking memory leak tracking code from
-# libcurl the generated curl/curlbuild.h file must also be reachable.
-# Using the libcurl lowlevel code from within c-ares library is ugly and
-# only works when c-ares is built and linked with a similarly debug-build
-# libcurl, but we do this anyway for convenience.
-#
-# $(top_builddir)/../include/curl for generated curlbuild.h included from curl.h
-# $(top_builddir)/../include is for libcurl's generated curl/curlbuild.h file
-# $(top_srcdir)/../include is for libcurl's external include files
-# $(top_builddir)/../lib is for libcurl's generated lib/curl_config.h file
-# $(top_srcdir)/../lib is for libcurl's lib/setup.h and other "private" files
-# $(top_builddir) is for c-ares's generated ares_config.h file
-# $(top_srcdir) is for c-ares's ares_setup.h and other "c-ares-private" files
-
-if CURLDEBUG
-AM_CPPFLAGS = -I$(top_builddir)/../include/curl \
- -I$(top_builddir)/../include \
- -I$(top_srcdir)/../include \
- -I$(top_builddir)/../lib \
- -I$(top_srcdir)/../lib \
- -I$(top_builddir) \
- -I$(top_srcdir)
-else
-AM_CPPFLAGS = -I$(top_builddir) \
- -I$(top_srcdir)
-endif
-
-lib_LTLIBRARIES = libcares.la
-
-man_MANS = $(MANPAGES)
-
-MSVCFILES = vc/vc6aws.dsw vc/acountry/vc6acountry.dsp vc/adig/vc6adig.dsp \
- vc/ahost/vc6ahost.dsp vc/cares/vc6cares.dsp vc/cares/vc6cares.dsw
-
-if CURLDEBUG
-PROGS =
-else
-PROGS = ahost adig acountry
-endif
-
-noinst_PROGRAMS =$(PROGS)
+MSVCFILES = msvc_ver.inc buildconf.bat
# adig and ahost are just sample programs and thus not mentioned with the
# regular sources and headers
-EXTRA_DIST = AUTHORS CHANGES README.cares Makefile.inc Makefile.dj \
- Makefile.m32 Makefile.netware Makefile.msvc Makefile.Watcom $(man_MANS) \
- config-win32.h RELEASE-NOTES libcares.pc.in buildconf get_ver.awk maketgz \
- TODO ares_build.h.in $(PDFPAGES) cares.rc README.msvc $(MSVCFILES) \
- $(CSOURCES) $(HHEADERS) config-dos.h acountry.1 adig.1 ahost.1 INSTALL \
- README.md LICENSE.md
+EXTRA_DIST = AUTHORS CHANGES README.cares $(man_MANS) RELEASE-NOTES \
+ c-ares-config.cmake.in libcares.pc.cmake libcares.pc.in buildconf get_ver.awk \
+ maketgz TODO README.msvc $(MSVCFILES) INSTALL.md README.md LICENSE.md \
+ CMakeLists.txt Makefile.dj Makefile.m32 Makefile.netware Makefile.msvc \
+ Makefile.Watcom AUTHORS CONTRIBUTING.md SECURITY.md TODO
+
CLEANFILES = $(PDFPAGES) $(HTMLPAGES)
-DISTCLEANFILES = ares_build.h
+DISTCLEANFILES = include/ares_build.h
-DIST_SUBDIRS = test
+DIST_SUBDIRS = include src test docs
+
+SUBDIRS = @BUILD_SUBDIRS@
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libcares.pc
-CARES_VERSION_INFO = -version-info 4:0:2
-# This flag accepts an argument of the form current[:revision[:age]]. So,
-# passing -version-info 3:12:1 sets current to 3, revision to 12, and age to
-# 1.
-#
-# If either revision or age are omitted, they default to 0. Also note that age
-# must be less than or equal to the current interface number.
-#
-# Here are a set of rules to help you update your library version information:
-#
-# 1.Start with version information of 0:0:0 for each libtool library.
-#
-# 2.Update the version information only immediately before a public release of
-# your software. More frequent updates are unnecessary, and only guarantee
-# that the current interface number gets larger faster.
-#
-# 3.If the library source code has changed at all since the last update, then
-# increment revision (c:r+1:a)
-#
-# 4.If any interfaces have been added, removed, or changed since the last
-# update, increment current, and set revision to 0. (c+1:r=0:a)
-#
-# 5.If any interfaces have been added since the last public release, then
-# increment age. (c:r:a+1)
-#
-# 6.If any interfaces have been removed since the last public release, then
-# set age to 0. (c:r:a=0)
-#
-
-AM_LDFLAGS =
-
-libcares_la_LDFLAGS_EXTRA =
-
-if CARES_LT_SHLIB_USE_VERSION_INFO
-libcares_la_LDFLAGS_EXTRA += $(CARES_VERSION_INFO)
-endif
-
-if CARES_LT_SHLIB_USE_NO_UNDEFINED
-libcares_la_LDFLAGS_EXTRA += -no-undefined
-endif
-
-if CARES_LT_SHLIB_USE_MIMPURE_TEXT
-libcares_la_LDFLAGS_EXTRA += -mimpure-text
-endif
-
-libcares_la_LDFLAGS = $(AM_LDFLAGS) $(libcares_la_LDFLAGS_EXTRA)
-
-# Add -Werror if defined
-CFLAGS += @CARES_CFLAG_EXTRAS@
-
-if USE_CPPFLAG_CARES_STATICLIB
-AM_CPPFLAGS += $(CPPFLAG_CARES_STATICLIB)
-endif
-
-libcares_la_CFLAGS_EXTRA =
-
-libcares_la_CPPFLAGS_EXTRA = -DCARES_BUILDING_LIBRARY
-
-if DOING_CARES_SYMBOL_HIDING
-libcares_la_CFLAGS_EXTRA += $(CFLAG_CARES_SYMBOL_HIDING)
-libcares_la_CPPFLAGS_EXTRA += -DCARES_SYMBOL_HIDING
-endif
-
-@CODE_COVERAGE_RULES@
-libcares_la_LDFLAGS += $(CODE_COVERAGE_LDFLAGS)
-libcares_la_CFLAGS_EXTRA += $(CODE_COVERAGE_CFLAGS)
-
-libcares_la_CFLAGS = $(AM_CFLAGS) $(libcares_la_CFLAGS_EXTRA)
-
-libcares_la_CPPFLAGS = $(AM_CPPFLAGS) $(libcares_la_CPPFLAGS_EXTRA)
-
-# Makefile.inc provides the CSOURCES and HHEADERS defines
-include Makefile.inc
-
-libcares_la_SOURCES = $(CSOURCES) $(HHEADERS)
-
# where to install the c-ares headers
libcares_ladir = $(includedir)
-# what headers to install on 'make install':
-libcares_la_HEADERS = ares.h ares_version.h ares_dns.h \
- ares_build.h ares_rules.h
-
-ahost_SOURCES = ahost.c $(SAMPLESOURCES) $(SAMPLEHEADERS)
-ahost_LDADD = $(top_builddir)/libcares.la
-ahost_CFLAGS = $(AM_CFLAGS)
-ahost_CPPFLAGS = $(AM_CPPFLAGS)
-
-adig_SOURCES = adig.c $(SAMPLESOURCES) $(SAMPLEHEADERS)
-adig_LDADD = $(top_builddir)/libcares.la
-adig_CFLAGS = $(AM_CFLAGS)
-adig_CPPFLAGS = $(AM_CPPFLAGS)
-
-acountry_SOURCES = acountry.c $(SAMPLESOURCES) $(SAMPLEHEADERS)
-acountry_LDADD = $(top_builddir)/libcares.la
-acountry_CFLAGS = $(AM_CFLAGS)
-acountry_CPPFLAGS = $(AM_CPPFLAGS)
-
-SOURCEDMANDIR = man3
-SOURCEDMANPAGES = ares_init.3
-
-clean-local: clean-sourced-manpages
-
-clean-sourced-manpages:
- @srcdmandir='$(SOURCEDMANDIR)'; \
- echo "rm -rf $(top_builddir)/$$srcdmandir"; \
- rm -rf $(top_builddir)/$$srcdmandir
-
-sourced-manpages: clean-sourced-manpages
- @srcdmandir='$(SOURCEDMANDIR)'; \
- srcdmanfiles='$(SOURCEDMANPAGES)'; \
- mkdir $(top_builddir)/$$srcdmandir; \
- for file in $$srcdmanfiles; do \
- if test -f $(top_srcdir)/$$file; then \
- echo "cp $(top_srcdir)/$$file $(top_builddir)/$$srcdmandir/$$file"; \
- cp $(top_srcdir)/$$file $(top_builddir)/$$srcdmandir/$$file; \
- fi; \
- done
-
-MAN2HTML = roffit --mandir=. < $< >$@
-
-SUFFIXES = .3 .html
-
-html: sourced-manpages $(HTMLPAGES)
-
-.3.html:
- $(MAN2HTML)
-
-pdf: sourced-manpages $(PDFPAGES)
-.3.pdf:
- @(foo=`echo $@ | sed -e 's/\.[0-9]$$//g'`; \
- groff -Tps -man $< >$$foo.ps; \
- ps2pdf $$foo.ps $@; \
- rm $$foo.ps; \
- echo "converted $< to $@")
# Make files named *.dist replace the file without .dist extension
dist-hook: