summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2015-02-03 16:22:55 +0100
committerDavid Sterba <dsterba@suse.cz>2015-02-03 17:13:55 +0100
commit1275c4fc1b31171706277a953ade9b0627c6686b (patch)
treea206d4b6883091efe00146d22e494647c4845d9c /configure.ac
parente1f0d9d4467a4025cada0443cecc0f9973eee145 (diff)
downloadbtrfs-progs-1275c4fc1b31171706277a953ade9b0627c6686b.tar.gz
btrfs-progs-1275c4fc1b31171706277a953ade9b0627c6686b.tar.bz2
btrfs-progs-1275c4fc1b31171706277a953ade9b0627c6686b.zip
btrfs-progs: autoconf: make btrfs-convert build optional
Proposed at https://github.com/kdave/btrfs-progs/pull/6, I've added the configure options. Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74e62b40..f523ba5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,6 +85,14 @@ if test "x$enable_documentation" = xyes; then
AC_PROG_SED
fi
+AC_ARG_ENABLE([convert],
+ AS_HELP_STRING([--disable-convert], [do not build btrfs-convert]),
+ [], [enable_btrfsconvert=yes]
+)
+
+AS_IF([test "x$enable_btrfsconvert" = xyes], [DISABLE_BTRFSCONVERT=0], [DISABLE_BTRFSCONVERT=1])
+AC_SUBST([DISABLE_BTRFSCONVERT])
+
dnl Define <NAME>_LIBS= and <NAME>_CFLAGS= by pkg-config
dnl