summaryrefslogtreecommitdiff
path: root/libs/assert/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/assert/CMakeLists.txt')
-rw-r--r--libs/assert/CMakeLists.txt17
1 files changed, 13 insertions, 4 deletions
diff --git a/libs/assert/CMakeLists.txt b/libs/assert/CMakeLists.txt
index f4ccdd9721..6cfd4f44b3 100644
--- a/libs/assert/CMakeLists.txt
+++ b/libs/assert/CMakeLists.txt
@@ -1,9 +1,9 @@
-# Copyright 2018, 2019 Peter Dimov
+# Copyright 2018-2023 Peter Dimov
# Distributed under the Boost Software License, Version 1.0.
-# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+# https://www.boost.org/LICENSE_1_0.txt
-# We support CMake 3.5, but prefer 3.16 policies and behavior
-cmake_minimum_required(VERSION 3.5...3.16)
+# We support CMake 3.5, but prefer 3.20 policies and behavior
+cmake_minimum_required(VERSION 3.5...3.20)
project(boost_assert VERSION "${BOOST_SUPERPROJECT_VERSION}" LANGUAGES CXX)
@@ -17,6 +17,15 @@ target_link_libraries(boost_assert
Boost::config
)
+if(CMAKE_VERSION VERSION_GREATER 3.18 AND CMAKE_GENERATOR MATCHES "Visual Studio")
+
+ file(GLOB_RECURSE boost_assert_IDEFILES CONFIGURE_DEPENDS include/*.hpp)
+ source_group(TREE ${PROJECT_SOURCE_DIR}/include FILES ${boost_assert_IDEFILES} PREFIX "Header Files")
+ list(APPEND boost_assert_IDEFILES extra/boost_assert.natvis)
+ target_sources(boost_assert PRIVATE ${boost_assert_IDEFILES})
+
+endif()
+
# BUILD_TESTING is the standard CTest variable that enables testing
if(BUILD_TESTING)