summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSathish Narasimman <sathish.narasimman@intel.com>2022-09-19 13:37:21 +0530
committerAyush Garg <ayush.garg@samsung.com>2023-05-15 14:55:54 +0530
commita1769d861608ed4331bbd84f224383f31acd3992 (patch)
treeb7aabf47d65a54ada57de7aabf6f3ba44bcaa97d /configure.ac
parent97fa64e2bda870c806cf75a713d6239dc1605eac (diff)
downloadbluez-a1769d861608ed4331bbd84f224383f31acd3992.tar.gz
bluez-a1769d861608ed4331bbd84f224383f31acd3992.tar.bz2
bluez-a1769d861608ed4331bbd84f224383f31acd3992.zip
profiles: Add initial code for vcp plugin
This adds initial code for vcp plugin which handles Volume Control Profile and Volume Control Service. Signed-off-by: Manika Shrivastava <manika.sh@samsung.com> Signed-off-by: Ayush Garg <ayush.garg@samsung.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ac16521..58a69c65 100755
--- a/configure.ac
+++ b/configure.ac
@@ -168,6 +168,10 @@ AC_ARG_ENABLE(bap, AS_HELP_STRING([--disable-bap],
[disable BAP profile]), [enable_bap=${enableval}])
AM_CONDITIONAL(BAP, test "${enable_bap}" != "no")
+AC_ARG_ENABLE(vcp, AS_HELP_STRING([--disable-vcp],
+ [disable VCP profile]), [enable_vcp=${enableval}])
+AM_CONDITIONAL(VCP, test "${enable_vcp}" != "no")
+
AC_ARG_ENABLE(tools, AS_HELP_STRING([--disable-tools],
[disable Bluetooth tools]), [enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")