summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAtul Rai <a.rai@samsung.com>2018-03-28 16:28:55 +0530
committerAtul Rai <a.rai@samsung.com>2018-03-29 09:48:16 +0530
commit66f0c2b8bca26ef10cf2be01be2d2b2ece737826 (patch)
treea5214654d4e160da069f8cf6af2d5ac195811804 /configure.ac
parent64a863836dcec4d5d19ab32375c994a8c3b214b6 (diff)
downloadbluez-66f0c2b8bca26ef10cf2be01be2d2b2ece737826.tar.gz
bluez-66f0c2b8bca26ef10cf2be01be2d2b2ece737826.tar.bz2
bluez-66f0c2b8bca26ef10cf2be01be2d2b2ece737826.zip
Enable check-TESTS using %check section in bluez
This patch enables check-TESTS (unit test case execution) for bluez at build time using %check section in bluez.spec. This patch, - Modifies unit/test-gobex.c, unit/test-gatt.c, unit/test-hog.c and unit/test-gattrib.c to handle Tizen specific changes in BlueZ. - Disables crypto test cases (unit/test-crypto) as QEMU (v2.7.0) in Tizen does not support AF_ALG socket option for cypher algorithms. Change-Id: I5a49ac00a26fe5c1baf92b02915cf1bcfa30f68b Signed-off-by: Atul Rai <a.rai@samsung.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 22561231..e0ffa617 100755
--- a/configure.ac
+++ b/configure.ac
@@ -349,6 +349,10 @@ AC_ARG_ENABLE(le, AC_HELP_STRING([--enable-le],
[Enable LE Plugin]), [enable_le=${enableval}])
AM_CONDITIONAL(TIZEN_LE_PLUGIN, test "${enable_le}" = "yes")
+AC_ARG_ENABLE(crypto-tests, AC_HELP_STRING([--disable-crypto-tests],
+ [Disable CRYPTO testcases]), [enable_crypto_tests=${enableval}])
+AM_CONDITIONAL(TIZEN_CRYPTO_TESTS, test "${enable_crypto_tests}" != "no")
+
# End of TIZEN_FEATURE_BLUEZ_MODIFY
AC_ARG_ENABLE(deprecated, AC_HELP_STRING([--enable-deprecated],