summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKoba Ko <koba.ko@canonical.com>2023-09-18 01:25:20 +0800
committerAyush Garg <ayush.garg@samsung.com>2024-01-05 19:04:04 +0530
commit444ce8d40f61bf7d855f7fd31e982879260fbc4b (patch)
tree113314e106fec6871810786e72afecec3e8c608b /configure.ac
parent3c1ebd221d30fb12cdcd4b89aaa867cce455dace (diff)
downloadbluez-444ce8d40f61bf7d855f7fd31e982879260fbc4b.tar.gz
bluez-444ce8d40f61bf7d855f7fd31e982879260fbc4b.tar.bz2
bluez-444ce8d40f61bf7d855f7fd31e982879260fbc4b.zip
configure.ac: Add enable_btpclient and enable_mesh for internal ELL
when checking enable_external_ell != 'yes', even enable_btpclient and enable_mesh are not enabled. configure still prompt the error. Then ELL must be installed to pass the configure.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b0833d41..1a15e55d 100755
--- a/configure.ac
+++ b/configure.ac
@@ -265,7 +265,8 @@ if (test "${enable_external_ell}" = "yes"); then
AC_SUBST(ELL_CFLAGS)
AC_SUBST(ELL_LIBS)
fi
-if (test "${enable_external_ell}" != "yes"); then
+if (test "${enable_external_ell}" != "yes" &&
+ (test "${enable_btpclient}" = "yes" || test "${enable_mesh}" = "yes")); then
if (test ! -f ${srcdir}/ell/ell.h) &&
(test ! -f ${srcdir}/../ell/ell/ell.h); then
AC_MSG_ERROR(ELL source is required or use --enable-external-ell)