summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2021-11-23 13:32:12 -0800
committerAyush Garg <ayush.garg@samsung.com>2022-03-11 19:08:38 +0530
commit3e43cea69d6bc062d50487dadf99d07c753dd895 (patch)
tree7cdf1bc6fa9aec4c0ece0371e556e1bf5c4ffc71 /configure.ac
parentf1bb0cb8560aed752d4037915266c989c346043c (diff)
downloadbluez-3e43cea69d6bc062d50487dadf99d07c753dd895.tar.gz
bluez-3e43cea69d6bc062d50487dadf99d07c753dd895.tar.bz2
bluez-3e43cea69d6bc062d50487dadf99d07c753dd895.zip
build: Check for linux/uinput.h and linux/uhid.h
This makes configure to check the presence of linux/uinput.h and linux/uhid.h kernel uapi headers since the code no longer contain copies of them and otherwise the code cannot be build without them: checking linux/uinput.h usability... yes checking linux/uinput.h presence... yes checking for linux/uinput.h... yes checking linux/uhid.h usability... yes checking linux/uhid.h presence... yes checking for linux/uhid.h... yes Signed-off-by: Anuj Jain <anuj01.jain@samsung.com> Signed-off-by: Ayush Garg <ayush.garg@samsung.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3657d507..c965e30f 100755
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,7 @@ AC_CHECK_LIB(pthread, pthread_create, dummy=yes,
AC_CHECK_LIB(dl, dlopen, dummy=yes,
AC_MSG_ERROR(dynamic linking loader is required))
-AC_CHECK_HEADERS(linux/types.h linux/if_alg.h)
+AC_CHECK_HEADERS(linux/types.h linux/if_alg.h linux/uinput.h linux/uhid.h)
PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.28, dummy=yes,
AC_MSG_ERROR(GLib >= 2.28 is required))