summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJunfeng Dong <junfeng.dong@intel.com>2013-05-21 18:20:33 +0800
committerJunfeng Dong <junfeng.dong@intel.com>2013-05-21 18:26:25 +0800
commitea519aab96f46e11040a83b5514a32f8608b6617 (patch)
treeb0cec3bade65f5ec9dd0399dc56e4b03dac51386 /CMakeLists.txt
parent29bb333cc76a2cee72e97748114650e2d650fa1e (diff)
downloadshell-ea519aab96f46e11040a83b5514a32f8608b6617.tar.gz
shell-ea519aab96f46e11040a83b5514a32f8608b6617.tar.bz2
shell-ea519aab96f46e11040a83b5514a32f8608b6617.zip
Add neccessary dependency management.
The commint is to fix the build error "cannot find -losp-shell-core" when not using "-j jobs". Change-Id: I962cf63724026f5134c0138c44b3513a5e54fc69
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 240a0e9..01535c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,6 +30,8 @@ LINK_DIRECTORIES (${LIBRARY_OUTPUT_PATH})
ADD_SUBDIRECTORY(src)
ADD_SUBDIRECTORY(src/core)
+ADD_DEPENDENCIES(osp-shell osp-shell-core)
+
# pkgconfig file
CONFIGURE_FILE(osp-shell.pc.in ${CMAKE_SOURCE_DIR}/osp-shell.pc @ONLY)
INSTALL(FILES ${CMAKE_SOURCE_DIR}/osp-shell.pc DESTINATION lib/pkgconfig)