summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 4 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index 9056022..44e3cd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,18 +100,18 @@ fi
# Dependencies for the library
PKG_CHECK_MODULES([MINIMAL],
[
- eina >= 1.0.0
- eet >= 1.4.0
+ eina >= 1.6.99
+ eet >= 1.6.99
])
PKG_CHECK_MODULES([MULTISENSE_PLUGIN],
[
- edje >= 1.0.0
+ ecore >= 1.7.99
mm-sound >= 1.0
remix >= 0.2.4
])
-requirement_edje_multisense_plugin="edje >= 1.0.0 mm-sound >= 1.0 ${requirement_edje_multisense_plugin}"
+requirement_edje_multisense_plugin="ecore >= 1.7.99 mm-sound >= 1.0 ${requirement_edje_multisense_plugin}"
AC_DEFINE(EAPI, __attribute__ ((visibility("default"))), "Public API Visibility")
@@ -134,36 +134,6 @@ AM_CONDITIONAL(HAVE_LIB_REMIX, test "x${HAVE_LIB_REMIX}" = xyes)
MULTISENSE_PLUGIN_CFLAGS="${MULTISENSE_PLUGIN_CFLAGS}"
MULTISENSE_PLUGIN_LIBS="${MULTISENSE_PLUGIN_LIBS}"
-PKG_CHECK_MODULES(SNDFILE, sndfile >= 1.0.21,
- HAVE_LIBSNDFILE1="yes", HAVE_LIBSNDFILE1="no")
-
-if test "$HAVE_LIBSNDFILE1" = "yes" ; then
- AC_DEFINE([HAVE_LIBSNDFILE1], [], [Define if libsndfile version 1 found])
- AC_SUBST(SNDFILE_LIBS)
- AC_SUBST(SNDFILE_CFLAGS)
-else
- AC_CHECK_LIB(sndfile, sf_open, HAVE_LIBSNDFILE1="maybe")
- if test "$HAVE_LIBSNDFILE1" = "maybe" ; then
- AC_MSG_ERROR([
-***
-*** libsndfile-1.0.21 or greater seems to exist on your system, however
-*** the pkg-config tool cannot find its build information.
-***
-*** Please set your PKG_CONFIG_PATH environment variable to include the
-*** directory in which sndfile.pc was installed. For example, sndfile.pc
-*** is installed in /usr/local/lib/pkgconfig by default; if that is the
-*** case do:
-***
-*** export PKG_CONFIG_PATH="\$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig"
-***
-*** then run this ./configure again. If you configured libsndfile with a
-*** different --prefix option, replace /usr/local above with that prefix.
-***
-])
- fi
-fi
-AM_CONDITIONAL(HAVE_LIBSNDFILE1, test "x${HAVE_LIBSNDFILE1}" = xyes)
-
### Checks for header files
AC_CHECK_HEADERS([locale.h])