summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..dc9a70c
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,20 @@
+TESTS = tlmnfctest
+TESTS_ENVIRONMENT= CK_FORK=no
+
+VALGRIND_TESTS_DISABLE=
+
+check_PROGRAMS = tlmnfctest
+tlmnfctest_SOURCES = tlmnfctest.c
+tlmnfctest_CFLAGS = \
+ $(TLM_NFC_CFLAGS) \
+ $(CHECK_CFLAGS) \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/src/
+
+tlmnfctest_LDADD = \
+ $(top_builddir)/src/libtlm-nfc.la \
+ $(GSIGNOND_LIBS) \
+ $(CHECK_LIBS)
+
+include $(top_srcdir)/test/valgrind_common.mk
+