summaryrefslogtreecommitdiff
path: root/packaging/optee-os-rpi3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/optee-os-rpi3.spec')
-rw-r--r--packaging/optee-os-rpi3.spec28
1 files changed, 22 insertions, 6 deletions
diff --git a/packaging/optee-os-rpi3.spec b/packaging/optee-os-rpi3.spec
index 6233480..f91c664 100644
--- a/packaging/optee-os-rpi3.spec
+++ b/packaging/optee-os-rpi3.spec
@@ -3,11 +3,14 @@
%if %{__isa_bits} == 64
%define compile_arch %{compile_flags} CFG_ARM64_core=y
%else
-%define compile_arch %{compile_flags}
+%define compile_arch %{compile_flags} CFG_WITH_VFP=n
%endif
+%define out_dir out/arm-plat-%{buildplat}
+%define export_dir export-ta_arm%{__isa_bits}
+%define out_export_dir opt/optee/
Name: optee-os
-Summary: OPTEE trusted operation system.
+Summary: OpTEE OS with userspace libraries and devkit for OpTEE OS.
Version: 2.4.0
Release: 1%{?dist}
Group: Security/Testing
@@ -18,6 +21,7 @@ ExclusiveArch: armv6l armv7hl armv7l aarch64
Provides: tee-pager.bin
Provides: tee.bin
+Provides: optee-os-ta
BuildRequires: make
BuildRequires: python
@@ -26,20 +30,32 @@ BuildRequires: openssl
%description
Trusted execution enviroment in Linux using the ARM® TrustZone® technology.
+%files
+/boot/tee-pager.bin
+/boot/tee.bin
+
%prep
%setup -q
%build
-make %{compile_arch} out/arm-plat-%{buildplat}/core/tee.bin
+make %{compile_arch}
%install
mkdir -p %{buildroot}/boot/
+mkdir -p %{buildroot}/%{out_export_dir}
cp -p %{_builddir}/%{name}-%{version}/out/arm-plat-%{buildplat}/core/tee-pager.bin %{buildroot}/boot/
cp -p %{_builddir}/%{name}-%{version}/out/arm-plat-%{buildplat}/core/tee.bin %{buildroot}/boot/
+cp -rf %{_builddir}/%{name}-%{version}/%{out_dir}/%{export_dir} %{buildroot}/%{out_export_dir}/
%clean
-%files
-/boot/tee-pager.bin
-/boot/tee.bin
+%package ta
+Summary: OpTEE OS userspace libraries and devkit for OpTEE OS.
+Group: Security/Testing
+
+%description ta
+Trusted execution enviroment in Linux using the ARM® TrustZone® technology.
+
+%files ta
+/%{out_export_dir}/%{export_dir}