summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorKyungwook Tak <k.tak@samsung.com>2015-07-13 10:43:23 +0900
committerKyungwook Tak <k.tak@samsung.com>2015-07-16 18:08:33 +0900
commitb854e72692792825c7d905df13eac186e73a1d2d (patch)
treecc22bc9ffed5f6b15c321c150667b2a47f9b1ad5 /tests/CMakeLists.txt
parentee8181dce4bc0f6c38db8b43c5f1ea0c021cc8d4 (diff)
downloadcert-svc-b854e72692792825c7d905df13eac186e73a1d2d.tar.gz
cert-svc-b854e72692792825c7d905df13eac186e73a1d2d.tar.bz2
cert-svc-b854e72692792825c7d905df13eac186e73a1d2d.zip
Update Tizen 2.4 latest codes
* remove dpl dependency (to wrt-commons) * cert-server service added, which is moved from secure-storage * add test codes - turn test build flag on in spec file to build test cases Change-Id: Id355e0e52220dd2b281a1a2225383fd366b876fe Signed-off-by: Kyungwook Tak <k.tak@samsung.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..ee84402
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Copyright (c) 2011 Samsung Electronics Co., Ltd All Rights Reserved
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+PKG_CHECK_MODULES(VCORE_TEST_DEP
+ REQUIRED
+ dpl-test-efl
+ sqlite3
+ )
+
+INCLUDE_DIRECTORIES(
+ SYSTEM
+ ${VCORE_TEST_DEP_INCLUDE_DIRS}
+ ${PROJECT_SOURCE_DIR}/include
+ ${PROJECT_SOURCE_DIR}/vcore/src
+ )
+
+ADD_SUBDIRECTORY(capi)
+ADD_SUBDIRECTORY(pkcs12)
+ADD_SUBDIRECTORY(vcore)
+ADD_SUBDIRECTORY(cert-svc)