summaryrefslogtreecommitdiff
path: root/packaging/org.tizen.net-popup.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/org.tizen.net-popup.spec')
-rw-r--r--packaging/org.tizen.net-popup.spec57
1 files changed, 57 insertions, 0 deletions
diff --git a/packaging/org.tizen.net-popup.spec b/packaging/org.tizen.net-popup.spec
new file mode 100644
index 0000000..dde4005
--- /dev/null
+++ b/packaging/org.tizen.net-popup.spec
@@ -0,0 +1,57 @@
+Name: org.tizen.net-popup
+Summary: Network Notification Popup application
+Version: 0.2.93
+Release: 1
+Group: App/Network
+License: Flora-1.1
+Source0: %{name}-%{version}.tar.gz
+BuildRequires: cmake
+BuildRequires: pkgconfig(appcore-efl)
+BuildRequires: pkgconfig(bundle)
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(ecore)
+BuildRequires: pkgconfig(edje)
+BuildRequires: pkgconfig(elementary)
+BuildRequires: pkgconfig(evas)
+BuildRequires: pkgconfig(syspopup)
+BuildRequires: pkgconfig(syspopup-caller)
+BuildRequires: pkgconfig(capi-appfw-application)
+BuildRequires: pkgconfig(gio-2.0)
+BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(notification)
+BuildRequires: pkgconfig(appsvc)
+BuildRequires: pkgconfig(vconf)
+BuildRequires: pkgconfig(efl-extension)
+BuildRequires: pkgconfig(libtzplatform-config)
+BuildRequires: pkgconfig(capi-vpnsvc)
+BuildRequires: pkgconfig(capi-network-stc)
+BuildRequires: pkgconfig(capi-system-info)
+BuildRequires: gettext
+BuildRequires: edje-tools
+
+%description
+Network Notification Popup application
+
+%prep
+%setup -q
+
+%define PKGNAME org.tizen.net-popup
+
+%build
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+ -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP}
+
+make %{?_smp_mflags}
+
+
+%install
+%make_install
+
+%files
+%manifest %{PKGNAME}.manifest
+/usr/apps/%{PKGNAME}/bin/net-popup
+/usr/apps/%{PKGNAME}/res/edje/*.edj
+%{_datadir}/packages/org.tizen.net-popup.xml
+%{_datadir}/locale/*/LC_MESSAGES/*.mo
+/usr/res/images/*.png
+%license LICENSE