summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c5dd9e..c8f1ffa 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ SET(SRCS
SET(PREFIX ${CMAKE_INSTALL_PREFIX})
SET(LOCALEDIR "${PREFIX}/share/locale")
SET(IMAGE_DIR "${PREFIX}/res/images")
+SET(PKG_NAME "org.tizen.net-popup")
IF("${CMAKE_BUILD_TYPE}" STREQUAL "")
SET(CMAKE_BUILD_TYPE "Release")
@@ -71,12 +72,12 @@ ADD_CUSTOM_TARGET(netpopup-custom.edj
ADD_DEPENDENCIES(${PROJECT_NAME} netpopup-custom.edj)
-INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
+INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${TZ_SYS_RO_APP}/${PKG_NAME}/bin)
# install desktop file & icon
SET(PREFIX ${CMAKE_INSTALL_PREFIX})
-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/edcs/netpopup-custom.edj DESTINATION /usr/ug/res/edje/net-popup/)
-INSTALL(FILES ${CMAKE_BINARY_DIR}/resources/net.netpopup.xml DESTINATION ${PREFIX}/share/packages/)
+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/edcs/netpopup-custom.edj DESTINATION ${TZ_SYS_RO_APP}/${PKG_NAME}/res/edje)
+INSTALL(FILES ${CMAKE_BINARY_DIR}/resources/${PKG_NAME}.xml DESTINATION ${PREFIX}/share/packages/)
INSTALL(DIRECTORY ${CMAKE_BINARY_DIR}/resources/ DESTINATION ${IMAGE_DIR} FILES_MATCHING PATTERN "*.png")
ADD_SUBDIRECTORY(po)