summaryrefslogtreecommitdiff
path: root/packaging/ui-gadget-1.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/ui-gadget-1.spec')
-rw-r--r--packaging/ui-gadget-1.spec20
1 files changed, 4 insertions, 16 deletions
diff --git a/packaging/ui-gadget-1.spec b/packaging/ui-gadget-1.spec
index 0c44937..7ea06fa 100644
--- a/packaging/ui-gadget-1.spec
+++ b/packaging/ui-gadget-1.spec
@@ -1,6 +1,3 @@
-%bcond_with x
-%bcond_with wayland
-
Name: ui-gadget-1
Summary: UI Gadget Library
Version: 0.2.5
@@ -15,9 +12,6 @@ BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(appcore-efl)
BuildRequires: pkgconfig(bundle)
BuildRequires: pkgconfig(dlog)
-%if %{with x}
-BuildRequires: pkgconfig(x11)
-%endif
BuildRequires: pkgconfig(appsvc)
BuildRequires: pkgconfig(elementary)
BuildRequires: pkgconfig(capi-appfw-application)
@@ -36,9 +30,6 @@ UI gadget library (development headers)
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
-%if %{with x}
-Requires: pkgconfig(x11)
-%endif
%description devel
Development files for %{name}
@@ -49,13 +40,10 @@ cp %{SOURCE1001} .
%build
MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
-%cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
--DTZ_SYS_ETC=%TZ_SYS_ETC \
-%if %{with wayland} && !%{with x}
--Dwith_wayland=TRUE
-%else
--Dwith_x=TRUE
-%endif
+%cmake -DFULLVER=%{version} \
+ -DMAJORVER=${MAJORVER} \
+ -DTZ_SYS_ETC=%TZ_SYS_ETC \
+ .
make %{?jobs:-j%jobs}