summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHwankyu Jhun <h.jhun@samsung.com>2017-04-24 13:57:47 +0900
committerHwankyu Jhun <h.jhun@samsung.com>2017-04-26 11:17:32 +0900
commitc43cad804c37c3281e3f7b997511d1f46347d2d9 (patch)
tree79bfe1ac6b5f6ffc2e549b1be3a2e9c8a0b363d4 /CMakeLists.txt
parent2f835bf0a44dd0825e8128032fc96282725c011f (diff)
downloadapp-core-c43cad804c37c3281e3f7b997511d1f46347d2d9.tar.gz
app-core-c43cad804c37c3281e3f7b997511d1f46347d2d9.tar.bz2
app-core-c43cad804c37c3281e3f7b997511d1f46347d2d9.zip
Support plugin for customizing appcore ui base
- APPCORE_UI_PLUGIN_INIT function The function will be invoked while initializing appcore ui base. - APPCORE_UI_PLUGIN_FINI function The function will be invoked while finalizing appcore ui base. Change-Id: Ifd0ab64b994e3dcea388c96dedd74b5415387d0c Signed-off-by: Hwankyu Jhun <h.jhun@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b4a9bd..bc52ac3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,7 +54,7 @@ ENDFOREACH(hfile)
# Build appcore-efl Library
# ------------------------------
SET(APPCORE_EFL "appcore-efl")
-SET(SRCS_efl src/legacy/appcore-efl.c src/ui_base/appcore_ui_base.c)
+SET(SRCS_efl src/legacy/appcore-efl.c src/ui_base/appcore_ui_base.c src/ui_base/appcore_ui_plugin.c)
SET(HEADERS_efl appcore-efl.h appcore_ui_base.h)
INCLUDE(FindPkgConfig)